Please be aware there is a known issue with images on the Community. We are working to resolve this issue as quickly as possible. We apologize for the inconvenience. If you need urgent help in the meantime, please reach out to technical support or your Threekit representative.

Can I exclude objects from a ShadowPlane?

Comments

3 comments

  • adamgravois
    adamgravois

    I am trying to use the ShadowPlane to generate floor shadows from the featured product. That works pretty well. I also have, in the scene, a mesh object for the floor. Problem: that floor object also casts a shadow. Onto ‘itself’. Eww.

    Is it possible to exclude the floor object from the shadow object’s calculation? Or fix this another way? The only way I’ve found is to move the floor and shadow plane pretty far apart from each other, but that is not a satisfactory solution, doesn’t look good.

    0
  • William  Thompson
    William Thompson

    Hey Adam, have you tried un-checking the ‘Casts Shadow’ box on the property of the model you would like to exclude? Let me know if this helps or not!

    0
  • adamgravois
    adamgravois

    Ah, thanks! That works.
    The setting I was looking for was within the model, not the scene, ok, makes sense.

    0

Please sign in to leave a comment.

Powered by Zendesk